M103: Basic Cluster Administration 2019_13_03

Hi there,
Why I cant find an ease step by step instruction about how to setup and validate Vagrant and VirtualBox to follow the Basic Cluster Administration? Seems to me that if the people have a step by step updated instruction about how to setup both Vagrant and VistualBox to use it, all problems will be solved. One more note, all information that I can read about Vagrant says that it is a .zip file that we can download, but I only find .msi Vagrant files… Is that correct now a day? If is correct, what` s are changes about setup steps?
In my computer I need to setup :
“C:\Users\sea-5\university\m103” for the parent directory, or
“C:\Users\sea-5\m103” for the parent directory?
And after that, I only need to copy the handout and place it in the m103 folder. Or I need to do the command to copy m103-vagrant-env on windows 10 pro 64bit?
Will be: “cp -r m103-vagrant-env C:\Users\sea-5\university\m103” ?
Note that, Vagrant is installed by default on ”C:\HashiCorp\Vagrant\” in the windows 10 pro.
I tryed every type of combination to setup my environment but nothing is going ok.
The file annexed is my actual state of erros.![errors|690x355]

And after that everything is ok and ready?
Sergio Eduardo Antonio

Hi Sergio,

Can you try the suggestions in this post Vagrant Issues on Windows to see if they resolve your issue ? I’d focus particularly on the last section which appears to be similar to your issue.

Hope this helps!

Hello everyone and hi Eoin,
About struggling with vagrant up on windows 10 pro:
It seems to me that I’m almost there.
Why am I saying this?
Now, I take the opposite direction on activating virtualization:
What did I do:
First: I’ve enabled my BIOs for virtualization
Second: I enabled all Hype-V and Platform Hypervisor in Windows
Third: I made an update on Microsoft’s Windows 10 pro
I am now looking at how to solve another problem that is shown in the attached file on SSH Time out.
Hopefully, if I solve the SSH Time Out problem, I might stop fighting the vagrant up on windows 10 pro.ErroAtual
Thank you all,

Nothing till now, no steps forwarding about SSH Time out while waiting for the machine to boot.
I’ve tryed some thinks but without results.
Is there someone from MongoDB University that can help???

Hi @Sergio_Eduardo_43032,

Please try doing ssh to your vagrant first after doing vagrant up.

.....\m103-vagrant-env> vagrant up
.....\m103-vagrant-env> vagrant ssh

If it does not work, then run below command:

.....\m103-vagrant-env> vagrant global status

And share us the output.


Hi Eoin,

Thanks for your attention about the problems that I’m find trying to setting up my computer to follow the course.

But my actual computer has Windows 10 Pro 64 bits on it, and I can’t understand how can I try your suggestion on my computer because my SO is different from Win-7 that is on your suggestion.

If you have information on how to do, please let me know.

And one more information, after that I tried a lot of times reinstallation and from each one the results was totally different.

Please, I think that to follow the course isn’t possible now, but I still want to learn about Cluster Administration.

If your have another idea about how to setup all the tools on a computer with windows 10 pro 64 bits, please let me know.

Again, “THANKS FOR YOUR ATTENCTION” and hopping to solve this kind of trouble.


Sergio Eduardo Antonio.

Hi MongoDB University sponsors,

Now with Windows 10 pro Hyper-V disabled and used Oracle VM VirtualBox 5.1.38 that was instruct to install following the “Lab: Setting Up the Vagrant Environment”, I have the following result

Please let me know if someone using Windows 10 Pro 64bits get all the environment working properly to follow the MongoDB Basic Cluster Administration.

Waiting an idea to solve this.



Hi @Sergio_Eduardo_43032,

Sorry for the trouble. With the setup issues, some suggestion works and some does not. Lets try and figure this one out. There are below links I found and one di

Let me know if anything works!