M042 mongod does not launch - Windows 10

I’m about 2:50 into the video and I enter everything except --fork. Nothing happens. Mongod does not launch. It appears to only move the log file.
Any help?

If you are using vagrant your prompt should look like vagrant@m042 but shows @localhost
I think you have to install vbox on Windows 10 itself

It is not giving any error means mongod is up.
Please check by ps -ef|grep mongod or check mongod.log
Try to connect using mongo --port xxxx

1 Like

Can you help me understand what this means and what I am doing wrong?


It looks like there maybe another mongod process already running. Which can be checked like @Ramachandra_37567 said with ps ef | grep mongod. If there is more than one line returned than you have a mongod running.

If not go into the /data/db directory and delete the mongod.lock file; and try again.

vagrant is installed from a previous lesson, but its installed on Windows 10 itself. i ran vagrant destroy and started the lesson over, it still says ‘localhost’. I have installed vagrant per the directions. Is my issue with mongo, vagrant, or the IP?

This an error I see during the provisioning of the vagrant VM:

Is that relevant?

I tried to browse to that location on the internet and it does not exist in that format…

I am not sure but looks like shell or environment problem
May be course instructors can help you
Try ssh vagrant@[hostname or IP as suggested in this

What does hostname,uname display after you are on vagrant box
Is mongod working

Thank you I am able to connect now.

Still not working:

But when I run the provision file for class M103 I get this: