M001 Mongodb basics

Getting following error
2 total, 0 passed, 0 skipped:
[FAIL] “Successfully connected to the Atlas Cluster”

Did you use the right command with the Atlas provided connection string?

[FAIL] “The username is m001-student”

Hi @RAJESH_SOMALINGAM, welcome to the community.

Can you please provide a screenshot of what commands you entered in the IDE before running the tests?
In case you have any doubts, please feel free to reach out to us.

Sourabh Bagrecha,
Curriculum Services Engineer

![Mongo db error2|690x380](upload://lTg9aRKRP9TeXQzyxgBnwttbiAz.png)

Looks like it is the same as

1 Like

Hi @RAJESH_SOMALINGAM, please note that the place where you entered your command is actually the file editor, you have to enter your command in the IDE, which is just below that text/file editor, having the heading as “terminal 0”. I hope your issue is now resolved and you were able to connect to your cluster from the IDE.
Thanks to Steeve for linking the previous similar post. You can refer to that post to follow the discussion.

In case you have any doubts, please feel free to reach out to us.

Thanks & Regards,
Sourabh Bagrecha,
Curriculum Services Engineer

I have placed the code in terminal 0 ,but still getting same error.Please check the snapshot attached

Attached the error details I got when I run code on terminal


Before hitting the Run Test button
Can you confirm the following
that :point_down:

  • After writing the command in the shell, you hit ENTER and then
  • Entered your password in the shell,
  • And again pressed ENTER to run it.


See the following thread for some answer:

1 Like

Sorry for posting the same answer as someone else. I did not see it. And guess who was complaining about that in a previous thread.

Thanks to Steeve , kesav and Sourabh for inputs and help me resolve my doubts



We are glad that your issue has been resolved.
So, for now I am closing this thread.

In case of any questions, please feel free to reach out.


1 Like