Localhost:5000 error

I run npm start and all right:

fabio@HP-Pavilion-Sleekbook-14:~/mflix-js$ npm start

server@1.0.0 start /home/fabio/mflix-js
nodemon -L ./index.js
[nodemon] 1.17.5
[nodemon] to restart at any time, enter rs
[nodemon] watching: .
[nodemon] starting node ./index.js
listening on port 5000

But when I try access localhost:5000:

GET / 304 5.464 ms - -
GET /static/css/main.d2c98b4b.chunk.css 304 2.999 ms - -
GET /static/js/1.85042e97.chunk.js 304 2.789 ms - -
GET /static/js/main.1ddf7b65.chunk.js 304 4.887 ms - -
GET /static/media/mongoleaf.0ebc1843.png 304 0.496 ms - -
GET /manifest.json 304 0.407 ms - -
Unable to convert cursor to array or problem counting documents, MongoError: user is not allowed to do action [find] on [mflix.movies]
GET /api/v1/movies/ 304 126.983 ms - -

And all stop…

The user in atlas does not have the appropriate privileges.

The user privilege is: “Atlas admin”.
Before, it was “read and write any database”, but it doesn’t work too.

Try connecting with mongo shell with same user and do find on the same collection.

I added “retryWrites=true” to URI and updated mongodb driver to 3.2.4 and it worked!!!
Thank you Steeve!

Nice good thinking. Have fun with mongo.