Loading data into the sandbox cluster


I am not able to load data into the sandbox cluster. Here is the error I’m getting:


What am I missing?

Hi Rose_26753,

Error suggests me to check if you are in the same directory where loadMovieDetailsDataset.js is present.

If not, move to that directory and then start your mongo and try again.


try logging out and connecting again once again…

Also any idea how to view the contents of insertMany-unordered.js files in windows 10 environments?

if you wanted to look at a javascript file you could use a text editor like atom or vs code. you can use notepad as well

I have and yet I’m still getting the same error. Plus I have restarted my mongo shell…
Here is my directory:


I found the problem. I was tying load(“loadMovieDetailsDataset.js”) instead of load(“M001/loadMovieDetailsDataset/loadMovieDetailsDataset.js”).
How come the former works great for some of us?

1 Like

Hi Rose_26753,

You have to present in loadMovieDetailsDataset directory and then start mongo.


/Users/Admin/M001/loadMovieDetailsDataset~: $ mongo ---
MongoDB shell version v4.0.3
> load("loadMovieDetailsDataset.js")



I am in “m001” fold

load(“loadMovieDetailsDataset.js”) does not work

but load(“loadMovieDetailsDataset”) without “.js”, it works

env: windows 10

Hi Kanika,
When I try to load Loadmoviedetaildataset.js file .I get the following error. I am running Mongo shell from the same M001 directory. Please help.

Hi Joseph_89514,

You have to connect to your sandbox cluster and not our: cluster0-shard-00-00-jxeqq.mongodb.net .

Thanks, Kanika

I can’t load the file:

2018-11-08T16:10:18.159-0600 I NETWORK [thread1] Successfully connected to sandbox-shard-00-02-203za.mongodb.net:27017 (1 connections now open to sandbox-shard-00-02-203za.mongodb.net:27017 with a 5 second timeout)
MongoDB server version: 4.0.4
WARNING: shell and server versions do not match
MongoDB Enterprise Sandbox-shard-0:PRIMARY> load (“loadMovieDetailsDataset.js”)
2018-11-08T16:11:08.273-0600 F - [thread1] Invalid access at address: 0
2018-11-08T16:11:08.276-0600 F - [thread1] Got signal: 11 (Segmentation fault).

0x562c19faed1a 0x562c19fadffe 0x562c19fae64c 0x562c1a117096 0x7f8edaa441b0 0x562c1a5ebc30 0x562c1a5d7246 0x562c1a5f12fb 0x562c1a5f19cd 0x562c1a5f2600 0x562c1a3eca80 0x562c1a3ecfd2 0x562c1a3ed37b 0x562c1a3ed5ba 0x562c1a5d8555 0x562c1a5dfaa8 0x562c1a4403b8 0x562c1a5b4e9c 0x562c1a5c426c 0x562c1a5c48ac 0x562c1a39fe1d 0x562c1a39ff25 0x562c1a3a004a 0x562c19e9ee16 0x562c19e7aa04 0x562c19eadcb3 0x562c19eb37d3 0x562c1a501431 0x562c1a4f4ae4 0x562c1a501150 0x562c1a5087b0 0x562c1a508911 0x562c1a39edba 0x562c1a39ee60 0x562c19e9eeb6 0x562c19ecd70f 0x562c19ecdb0f 0x562c19e8262c 0x7f8edb26e53f 0x7f8edaa3950b 0x7f8eda77116f

I’m using mongo installed on Linux Fedora 27 machine

Something went wrong with my installation on fedora system.

I installed mongo shell on a centos 7 machine and loading file worked fine.
Thanks anyway.

1 Like