Launching mongod Error

image

Please help me out with this error!!

When you see the string MongoDB Enterprise > you are in the mongo shell.

When you see the string vagrant@m103:~$ you are in the vagrant “shell”.

You got the first syntax error because the commands ps and grep are shell commands. You type it at the vagrant shell.

You got the second syntax error because the command mongo is the command that starts the mongo shell. You type it at the vagrant shell. But you were already in the mongo shell.

You could not create the user because it already exist. You created it in a previous lab.

You got Authentication failed because you specified user and pwd as the user name and password. You actually have to use a real user name and password. Most likely the one you are trying to create.

You got dd is not defined because it is db.shut….

We will need the output of the command ss -tlnp, at the vagrant shell, to see why validate_… fails.

1 Like

Hi Team,

I can see user already exists but when i run validate command its asking for binding the ip address.

i tried binding the ip address with ( --bind_ip localhost, 192.168.103.100 ) its throwing me dumps with error as Aborted (core dumped )

Please help me out with this!!


Please shutdown or kill any existing mongod instance(core dump aborted may be because of that or missing dir paths)
Run your command again with bindip
Also make sure to remove space between the localhost and IP and the dirs exist for dbpath and logpath

1 Like

Hi Team,

In the attached screenshot i can see there are 88 processes running !!

Should i delete all this instances?
If yes can you please let me know how to do it?

Still i am getting dumps and i have lab due in 2 days.
I can see user created but not able to bind the ip address

Please let me know the complete steps or how to delete everything and start from the scratch

I have mentioned existing mongod instance
You should not kill other processes
You can check currently running mongods with below command
ps -ef|grep mongod
Once you get the process using PID(process ID) kill the session

or use
db.shutdownServer() at mongo shell

Hi Team,

Please check the screenshots attached!!

I have followed the steps asked and still finding it difficult to validate the user created.

I have killed the session using ps -ef|grep mongod still facing dumps error.

Let me know how to bind the ip address

p.s i know the syntax how to bind but getting short dumps if i execute the command and if i kill the session and try again still getting dumps

Please go through the screenshots and let me know if i am doing anything wrong

Help ASAP!!

Thank you

I

Kill the session again > delete all the data files > startup mongod