Launching Mongod - child process failed, exited with error number 1

When I use
mongod --dbpath /data/db --logpath /data/log/mongod.log --port 27000 --fork --bind_ip “localhost,”

I get the Error

about to fork child process, waiting until server is ready for connections.

forked process: 8948

ERROR: child process failed, exited with error number 1

To see additional information in this output, start without the “–fork” option

I checked out the discussion forum and tried several different possible versions of that command. I do not understand why it does not work.

Can you help me please? I am stuck since several days on this topic and I cannot continue the course.

Have you try to run without --fork from your command?
Did you check your mongod.log

Most likely missing dir for dbpath or some permissions issue

When I try to run it without --fork I get the following error

2019-12-29T10:23:55.978+0000 F CONTROL [main] Failed global initialization: FileNotOpen: Failed to open “/data/log/mongod.log”

So please check why it is unable to create the mongod.log
Did you create db and log dirs under /data with necessary permissions?

Thank you I did not check it out. I will do that now.

I figured it out in the end:

So I now only specified the following


then it worked.

Closing the thread as the issue has been resolved.