Lab1 not working

Hello,

I seriously need help on this lab. I dont know , what I missed.

I tried to connect 27000 but not working .

Here are the screenshots.

Capture1 Capture2

Thanks in advance.

Please check your logpath

data/db is not same as /data/db

Thanks. It connected. Now I created user.
and this error.

I am doing this on VM.

You have to run the command outside mongo prompt
Exit and run.It should work

1 Like

It shows me error as
Error: couldnt add user: there are no users authenticated

Are you able to get past this?

Try to login with the user

Hi @RK30,

Any update on this ?

~ Shubham

No …Its same error…

It means you are already have a user configured. It means the localhost exception is not available anymore. It means you have to authenticate to do anything. Please go back in earlier lessons and read about the localhost exception.

I tried this link
https://docs.mongodb.com/manual/tutorial/enable-authentication/

which works for default port, but same steps not working for port27000.

Thanks

You get

because authentication is enabled AND you have to authenticated. There is 3 ways to authenticate
1.command line arguments
2.connection string
3.db.auth() shell command

1 Like

solved already now from lecture .

Thanks for the suggestions

Hi @RK30,

I’m glad your issue got resolved. Please feel free to get back to us if you have any other query.

~ Shubham

1 Like