Lab1: launching Mongdb

2020-03-22T13:50:42.565+0900 I CONTROL [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols ‘none’
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] MongoDB starting : pid=2165 port=27000 dbpath=/data/db 64-bit host=Macobooks-MBP
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] db version v4.2.0
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] git version: a4b751dcf51dd249c5865812b390cfd1c0129c30
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] allocator: system
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] modules: enterprise
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] build environment:
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] distarch: x86_64
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] target_arch: x86_64
2020-03-22T13:50:42.572+0900 I CONTROL [initandlisten] options: { net: { bindIp: “192.168.103.100,localhost”, port: 27000 }, security: { authorization: “enabled” } }
2020-03-22T13:50:42.574+0900 E STORAGE [initandlisten] Failed to set up listener: SocketException: Can’t assign requested address
2020-03-22T13:50:42.577+0900 I CONTROL [initandlisten] now exiting
2020-03-22T13:50:42.578+0900 I CONTROL [initandlisten] shutting down with code:48

I am stuck in here

Are you using vagrant or local host for your work?
starting : pid=2165 port=27000 dbpath=/data/db 64-bit host=Macobooks-MBP
host should show m103 in the above
Please show screenshots of where you are running the mongod commands

1 Like

oH…you right!
I didn’t understand well to use vagrant host. Now it is working.
Thank you so much for remind me…

Closing this thread as the issue has been resolved.