Lab: Setting Up the Vagrant Environment

Microsoft Windows [Version 10.0.18362.356]
© 2019 Microsoft Corporation. All rights reserved.

C:\Users\Rohit\m103\m103-vagrant-env>vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Importing base box ‘ubuntu/trusty64’…
==> mongod-m103: Matching MAC address for NAT networking…
==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “876bf5d7-6982-4201-8689-cfa10453e047”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole


Need help(Tried 20 times even noot able to do :cold_sweat::cry:) for below error as i have tried all way but not able to resolve it :-

Hi @Rohit_84793,

Can you please try disabling hyper-v and and then re-provision your vagrant?

As long as Hyper-V is enabled, other hypervisors cannot run, including VirtualBox (and therefore Vagrant).

Please let me know if you still face any issues.

Curriculum Support Engineer

Thanks :slight_smile:

1-search cmd and run as a administrator
2-execute below command
bcdedit /set hypervisorlaunchtype off
3-Restart the system
4-Problem solved for me atleast finnaly :slight_smile:

1 Like