Lab - Logging to a Different Facility Timeout Error

I can’t figure out why I’m getting this error. The port and user are both set up correctly from what I know.

image

Any guidance is greatly appreciated.

Thanks,

I can see that you went ahead to validate straight after firing up the mongod, but there’s no evidence of you testing that you can actually connect.

By the way, the screenshot of your config file is revealing lab answers so you’d need to delete that particular screenshot.

1 Like

I’m assuming this means I’m able to connect via that port just fine. I am curious as to why it’s giving me this error when I try to show the databases though.

It means that you haven’t created the root user.

Odd since I did for earlier labs and it worked fine.
image

I went ahead and readded the user and it gave me this error.
image

I went ahead and disabled forking in the config file temporarily and now it’s giving me this error.

image

You can’t run mongod twice on the same port without shutting it down. Plus there’s no need to shut it down if all you did was add the first user.

Go ahead and verify that you can connect on both hosts.

image
Was able to connect to both the local host and 192.168.103.100 just fine (I’m just showing the local host here, both gave the same error). still getting the same user error from earlier for some reason.

You’re connected but not authenticated. Have a look at the mongo documentation for the options required to authenticate. Post back if you need some assistance.

1 Like

so it looks like the issue was that I was attempting to run two mongod sessions on the same port and after killing all the running sessions, it seemed to work fine. that authentication issue though was still persisting which I figured out by expanding out my mongo option command

Thanks for the help. This took way longer (and some hair being pulled out in the process) but I’m glad I got this sorted.

Thanks again

Hi @Patrick_94003,

I’m glad your issue got resolved. Please feel free to get back to us if you have any other query.

~ Shubham