Lab: Logging to a Different Facility - No successful validation

Hi there,

i’m kind of getting stuck with this lab. As specified i’ve included in the configuration file all the necessary configuration file settings to do the following:

  • Change the log path to “/var/mongodb/logs/mongod.log”

  • Fork to let run mongod as a daemon in background

from what i can see, the deamon seems to be starting fine and the yaml file is valid. Here the message after running the mongod --config mongod.conf command:

about to fork child process, waiting until server is ready for connections.
forked process: 610
child process started successfully, parent exiting

And the logs are outputted to the correct file:

user@M103# tail -f /var/mongodb/logs/mongod.log
2022-05-11T17:10:03.009+0000 I FTDC     [ftdc] Unclean full-time diagnostic data capture shutdown detected, found interim file, some metrics may have been lost. OK
2022-05-11T17:12:21.980+0000 I NETWORK  [listener] connection accepted from 127.0.0.1:50774 #1 (1 connection now open)

If i check the processes, i see the mongod running:

user@M103# ps -ef | grep mongod
  610 root      0:02 mongod --config mongod.conf

if i run the tests tho, it seems none of the cofigurations passed via the file are working:

2 total, 0 passed, 0 skipped:
[FAIL] "Mongod was started with the new logpath"

Did you launch mongod with the logpath /var/mongodb/logs/mongod.log?

[FAIL] "Mongod process was forked"

Did you modify your mongod configuration to fork the process?

For obvious reasons I cannot post my conf file solution and I hope all other info are enough to give me a hint on how to solve this.
Is it possible that in someway the IDE Test validator is giving me wrong results?

Thanks,
Roberto

Solved! My issue was due to the fact that i was trying validating before creating the user to do so !

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.