Lab: Launching Mongod

I am facing some issue while running “validate_lab_launch_mongod” step.
Here are my details performed in server and client side as per instruction given…:

Server side:
Command used:
mongod --port 27000 --dbpath /data/db --bind_ip “,”

2019-05-19T11:52:43.172+0000 I CONTROL [initandlisten] MongoDB starting : pid=4008 port=27000 dbpath=/data/db 64-bit host=m103
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] db version v3.6.12
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] git version: c2b9acad0248ca06b14ef1640734b5d0595b55f1
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1f 6 Jan 2014
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] allocator: tcmalloc
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] modules: enterprise
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] build environment:
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] distmod: ubuntu1404
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] distarch: x86_64
2019-05-19T11:52:43.173+0000 I CONTROL [initandlisten] target_arch: x86_64
2019-05-19T11:52:43.174+0000 I CONTROL [initandlisten] options: { net: { bindIp: “,”, port: 27000 }, storage: { dbPath: “/data/db” } }
2019-05-19T11:52:43.174+0000 I - [initandlisten] Detected data files in /data/db created by the ‘wiredTiger’ storage engine, so setting the active storage engine to ‘wiredTiger’.
2019-05-19T11:52:43.174+0000 I STORAGE [initandlisten]
2019-05-19T11:52:43.174+0000 I STORAGE [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
2019-05-19T11:52:43.174+0000 I STORAGE [initandlisten] ** See
2019-05-19T11:52:43.175+0000 I STORAGE [initandlisten] wiredtiger_open config: create,cache_size=488M,session_max=20000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),compatibility=(release=“3.0”,require_max=“3.0”),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),statistics_log=(wait=0),verbose=(recovery_progress),
2019-05-19T11:52:44.760+0000 I STORAGE [initandlisten] WiredTiger message [1558266764:760811][4008:0x7ffb7296aa80], txn-recover: Main recovery loop: starting at 3/10880
2019-05-19T11:52:44.906+0000 I STORAGE [initandlisten] WiredTiger message [1558266764:906272][4008:0x7ffb7296aa80], txn-recover: Recovering log 3 through 4
2019-05-19T11:52:45.001+0000 I STORAGE [initandlisten] WiredTiger message [1558266765:1308][4008:0x7ffb7296aa80], txn-recover: Recovering log 4 through 4
2019-05-19T11:52:45.078+0000 I STORAGE [initandlisten] WiredTiger message [1558266765:78294][4008:0x7ffb7296aa80], txn-recover: Set global recovery timestamp: 0
2019-05-19T11:52:45.130+0000 I CONTROL [initandlisten]
2019-05-19T11:52:45.130+0000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled for the database.
2019-05-19T11:52:45.130+0000 I CONTROL [initandlisten] ** Read and write access to data and configuration is unrestricted.
2019-05-19T11:52:45.130+0000 I CONTROL [initandlisten]
2019-05-19T11:52:45.139+0000 I FTDC [initandlisten] Initializing full-time diagnostic data capture with directory ‘/data/db/’
2019-05-19T11:52:45.141+0000 I NETWORK [initandlisten] waiting for connections on port 27000
2019-05-19T11:53:59.404+0000 I NETWORK [listener] connection accepted from #1 (1 connection now open)
2019-05-19T11:53:59.405+0000 I NETWORK [conn1] received client metadata from conn1: { application: { name: “MongoDB Shell” }, driver: { name: “MongoDB Internal Client”, version: “3.6.12” }, os: { type: “Linux”, name: “Ubuntu”, architecture: “x86_64”, version: “14.04” } }
2019-05-19T11:53:59.466+0000 I NETWORK [conn1] end connection (0 connections now open)

Client Shell side:

mongo admin --host localhost:27000 --eval ‘db.createUser({ user: “m103-admin”, pwd: “m103-pass”, roles: [{role: “root”, db: “admin”}]})’

MongoDB shell version v3.6.12
connecting to: mongodb://localhost:27000/admin?gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“f827809c-922b-4827-82b3-1a25b8f210bb”) }
MongoDB server version: 3.6.12
Successfully added user: {
“user” : “m103-admin”,
“roles” : [
“role” : “root”,
“db” : “admin”

Now while running below its giving error:

vagrant@m103:~$ validate_lab_launch_mongod
You need to bind the IP address to

Please suggest.


There is space between IP’s here