Lab: Importing a dataset. Unable to connect to mongod process

Hi,

I am having issues connecting to the mongod process.
The given mongod.conf file is as follows
storage: dbPath: /var/mongodb/db net: bindIp: localhost port: 27000 security: authorization: enabled systemLog: destination: file path: /var/mongodb/logs/mongod.log logAppend: true processManagement: fork:true
I tried running the following command:
mongod --config mongod.conf

and I got the following error:
about to fork child process, waiting until server is ready for connections. forked process: 354 ERROR: child process failed, exited with error number 48 To see additional information in this output, start without the "--fork" option.

So I followed the error message and removed the fork option in the config file but then when I ran the same command, nothing happened. No error or any output message.

Thanks in advance for the help :grinning:

Hi @Zephaniah,

Welcome to the MongoDB Community Forums.

Can you kindly reset your space by clicking on Reset Workspace and try with the correct command?

As in this lab, there is no need for running the above command.
I will suggest you read the problem statement carefully and try again.

We wish you All the best. :sparkles:
In case of any doubts, please feel free to reach out to us. We will be happy to help.!!

Thank you,
Kushagra

1 Like