Lab: Deploy a Replica Set : File Not Found

When I first started the activity I was able to start up a mongod process with all three files and I believe I was even able to initiate the nodes.

All I had left to do was “reconnect to your primary node as m103-admin and add the other two nodes to your replica set using rs.add()” but it kept failing. So I restarted the browser to start all over but it keeps saying file not found when the file is clearly sitting right there.

I have tried the following steps:

  • Using mkdir to dynamically create the file and even tried changing the name in the .conf file as well as while using “mkdir
  • Started over following each step as indicated in the lecture video using the correct file and path names that were requested still no result.

May be you are not in the correct directory
Show output of pwd

Hi :wave: @kaijyu_shinjyu,

We believe you might have resolved your error. If yes, we can close this thread or you can drop your follow-up question here. We will be glad to help! :sparkles:

Thanks,
Kushagra