Lab: Connect to your Atlas Cluster (with browser ide) | Error in tests

So… there is a problem with tests.
I can connect to db.
I can connect to db via credentials: user m001-student, but:

I dont’t see any typos in all configuration.
Used a connectionString:
mongosh “mongodb+srv://sandbox.vipwu.mongodb.net/myFirstDatabase” --username m001-student

(I replaced myFirstDatabase with base: sample_weatherdata

1 Like

Hey @Jaroslaw_Switlikowski,

Welcome to the MongoDB community forums :sparkles:

Can you please try connecting to your atlas cluster using mongo instead of mongosh? It will work as expected.

For example:
mongo "mongodb+srv://sandbox.xxxxx.mongodb.net/myFirstDatabase" --username <username> .

We are working to update the test case to support monogsh. We regret the inconvenience caused to you.

Kindly,
Kushagra

2 Likes

Maybe its worth to say it in the assignment ?

** I’m not OP

Actually, the lab instructions indicate to use mongo shell. In the example they supplied the command is:

mongo "mongodb+srv://..."

However, the new Atlas UI presents the command to cut-n-paste as

mongosh "mongodb+srv://..."

The mongosh shell is new and mongo shell is legacy. It is a transition period and Atlas evolved faster than associated training.

Both the error you encountered and the delay to adjust training are understandable. They both give the opportunity for all to learn something. Enjoy the rest of the course.

2 Likes

Thanks ! It worked.
I have been deleting clusters, projects, tinkering database access, network access settings for almost an hour.
Kindly include it in Lab instructions. It will be helpful for others.

1 Like

Hey, When I try to connect using mongo , I’m unable to type or paste password but when I try to connect using mongosh, I’m able to successfully connect but don’t know why I fail second test case i.e., [FAIL] “The username is m001-student”

Hey @Arya_Singh,

When you try connecting with mongo the password field is not visible in the IDE(linux terminal), so just enter the correct password and hit enter. It will work as expected.

Whereas while trying with our new mongosh shell, the password visibility has been added to the IDE so it becomes more convenient for the users.

We are working to add the support of mongosh. We will update you soon.

In case you need any other help please feel free to reach out to us.

Thanks,
Kushagra


am not able to pass the test

Hey @NEETPREDICTOR_N_A,

Welcome to the MongoDB Community forums :sparkles:

Can you share your srv connection string with us?

Can you make sure that you are connecting to your atlas cluster with the username m001-student?

Thanks,
Kushagra

1 Like

Thanks it worked .Wasted my one hour ,must update it so that new users don’t face same issue.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.