Lab: Configuration File

Hey all.
So I have been stuck on this lab for a long time. I am unable to pass it because it states that I have not started mongod using a configuration file. It would be very helpful if someone could help me out in the same.
I’m posting the snippets of the process for your perusal.



The mongod you launched is thru command line not thru config file
Hence the error
Try with config file

The command mongod --auth --port 27000 is wrong for this lab.

Step 2 of this lab reads:

  1. When your config file is complete, launch mongod with the --config command line option:

    mongod --config mongod.conf

    or using the -f option:

    mongod -f mongod.conf

Make sure you do step 1 first.

In the future please post screenshot of the whole IDE. What is happening in the other areas of the IDE are sometimes useful for diagnostic.

So according to the instructions given, I wrote my configuration file in the IDE File Editor. While trying to launch mongod with the --config command line option, I’m getting the following:

Indentation is important in YAML file

Reove extra space between port and colon(":")
Move port field by one space to the right under net
Move authorization field to the right by one space under security
Do not use tab(use space bar)


Thank you so much. I passed the following lab. :slight_smile: