Lab: Configuration File - Run test Issue

Hi

I was trying to complete a lab “Configuration File” and i am facing an issue with Run Test. I tried to search for the similar issue in the forums but couldn’t find any. Please help me in this matter.

mongod.conf file contains
net:
port: 27000
security:
authorization: enabled

and I ran below command in the terminal
mongod --config mongod.conf

When I click on Run Test it is showing 1 pass and 2 others fail
[3 total, 1 passed, 0 skipped:
[PASS] “The server is running on localhost:27000”
[FAIL] “The server requires authentication”

Don’t forget to launch mongod with authentication enabled!
You can do this using the configuration file.

[FAIL] “Mongod was started with a configuration file”

Did you launch mongod using a configuration file?]

I tried different ways but couldn’t get it right. Please help

Thanks
Naveen

Is your mongod up?Are you able to connect to it
Have you created the user?

1 Like

Oh yeah my bad, I was literally trying to run the test without creating user.

Thanks for the help Ramachandra !!

The test is now successful.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.