Lab: Configuration File - Config File Unit Test Failing

I have created the configuration file as instructed, and created a new user as per the instructions on the lab.

When I run the tests I get the final test failing:
[FAIL] “Mongod was started with a configuration file”

But I did start it with the CLI and I did it using the config file. I’ve run it several times now and it still fails.

Anyone got any ideas?

Switch to Terminal 1 and share a screenshot of running the command:

ps -aef | grep [m]ongod

Then connect to mongod with:

mongo --port 27000

Once connected share a screenshot of running the mongo shell commands:

use admin
db.getUsers()
2 Likes

@steevej thank you for the response. I have just logged in to try your proposed fix, and its magically worked before implementing the above. I will include the screenshots as you have asked in case someone else finds it useful in the future.

1 Like

If you are reading this, the below is a screenshot of the first command recommended by steevej.

NOTE: this is once all the tests started working, so may be different if you are having issues with your instance.