Lab - Change the Default DB Path for validate_lab_change_dbpath

Getting Error -
image

User for admin -
image

config file -
image

Please provide the output of the commands

ps -aef | grep [m]ongo
ss -tlnp

As the message indicates mongod is not running at the correct port or the user has not the appropriate settings.

removed the details and created the new topic

Output of commands you asked for -

@damodhar_vadlamudi different lab. Create a new thread and paste whatever @steevej-1495 suggested in there.

There is something funny.

You have 2 mongo running and connected to localhost:27000 and yet you have no mongod running?

I tried kill them both and tried it again, but again 2 mongod runs.

I saw no mongod running but 2 mongo.

They are not the same. One is the server. The other is the shell.

1 Like

Hi @chirag_39669,

The output in post #4 is a little strange as @steevej-1495 mentioned earlier.

Please do the following and share a screenshot :

  1. Run the configuration file that you created for this lab Change the Default DB Path.

  2. Connect to this mongod instance by running this command :

    mongo --port 27000 -u m103-admin -p m103-pass

    Switch to admin database

    use admin

  3. Run this command and share the output :

    db.adminCommand( { getCmdLineOpts: 1 } )

  4. Run the validator at the vagrant prompt and share the outuput.

Thanks,
Shubham Ranjan
Curriculum Services Engineer