Lab: Analyse Profiler Data unable to copy profiler*.json

I was able to start the VM and then also mlaunch --single, but when I gave command
cp Downloads/profiler*.json m312-vagrant-env/dataset, getting error as no such file or directory.
Then I thought you want me to import profile.json, so I downloaded the file into my vagrant environment E:\MongoDB\M312\m312-vagrant-env\dataset, then from within my vagrant machine I tried to run the below mongoimport command

mongoimport -d m312 -c /dataset/profile.json

the system started giving following messages continuously till I break it with Ctrl+c

2022-04-14T04:26:16.096+0000 connected to: localhost
2022-04-14T04:26:19.098+0000 m312./dataset/profile.json 0B
2022-04-14T04:26:22.097+0000 m312./dataset/profile.json 0B
2022-04-14T04:26:25.096+0000 m312./dataset/profile.json 0B

My assumption being I would have downloaded profiler.json file somewhere. However, there is only profile.json file in the lab.
Also, I tried to give the command

db.setProfilingLevel(1, 40)

getting error as " -bash: syntax error near unexpected token `1,40’

I checked all the previous posts on this topic, but could not find answer.

I am lost at this point.
Any help will be greatly appreciated.
Thank you
Siva

You have to run mongoimport in your vagrant env
Looks like you are trying it on your localhost
For db.profiling you have to connect to your db and then run the command
Looks like you ran it at os prompt
Screenshots will help in troubleshooting

Hi Ram,
Thanks for your hint. I reinstalled vagrant environment and I was able to import profiler collection and there are 195 documents in this collection.
Now, which parameter I should look for to know the index that caused the delay?
Obviously, I can not examine all the 195 documents in profiler_data collection

You have to filter your data.Check for queryplanner,ts fields.Filter by IXSCAN