Its the script has error?


one the script: how_data_is_stored_on_disk.sh, line 31, its need addtional add remove old db?
like line 14,15.


I seen that the third mongodb server listed the hello db file subdirectory not exists,but like the second one,so there had some error when the third one starting,and then i check the script that i found it

I have not looked at details of sh script but possible something is missing.Course instructors can clarify
It brought down db fine but when trying to bring up with wiredtiger storage option failing
This is from performance course but you are testing on vagrant@m103 box?
Is it due to mount point /dataset

1 Like

yeah,i run the performance course script on the vagrant@m103 environments.but after the first startup mongod server instance,there has remove the old db files directory;so that must be the second step has some mistakens

Hi @Elemi,

Let me check and get back to you on this. It should have worked in the M103 vagrant setup as well.

Please feel free to reach out if you have any questions.

Thanks,
Sonali

--wiredTigerDirectoryForIndexes is conflicting with the existing directory setup.

  1. To resolve the issue, add the lines in yellow:
    image

  2. To see which command that’s being run, add this line in yellow:
    image
    Surprised this wasn’t there in the first place.

1 Like