Issues starting VM on windows 7 following lessons and versions as listed

Installed the below:

  1. Virtualbox-5.1.38-122592-Win.exe
  2. Vagrant _1.9.6_x86_64.msi
    In Windows 7, Hyper-V is not included and so there’s isn’t need to disable them and run vagrant. Disabled anti virus and ran Vagrant, still not coming up :frowning:

vagrant start up error below:

Must redirect to new repository for old Vagrant versions
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “a61ca821-4eb6-4310-bc41-56f564cb6b62”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole.

Help needed to proceed further.


I suggest you check all threads on vagrant and try different options
If nothing works class instructors can help you further

Thanks, Ramachandra_37567 for your tips. I am doing and researching the same for few days and couldn’t start up vagrant.

Also I have the screen shots as the Virtualbox is suggesting the below. Not sure what should I change in the network setting.


Hi Sankar_79615,

Please try the following:

Whether your PC uses BIOS or UEFI, once you’re in the settings menu, you can begin looking around for an option labeled something like “Intel VT-x,” “Intel Virtualization Technology,” “Virtualization Extensions,” “Vanderpool,” or something similar.

Often, you’ll find the option under a “Processor” submenu. That submenu may be located somewhere under a “Chipset,” “Northbridge,” “Advanced Chipset Control,” or “Advanced CPU Configuration” menu.

Enable the option and then select “Save and Exit” or the equivalent feature to save your settings changes and reboot your PC.



Thanks, Kanika. With your suggestions I could enable Hardware Virtualization and now my VM is running and vagrant as well.

  1. I get some errors when I run ‘Vagrant Provision’.

==> mongod-m103:
==> mongod-m103: "The output above "
==> mongod-m103: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1
==> mongod-m103:
==> mongod-m103: Successfully installed pymongo
==> mongod-m103: Cleaning up…
==> mongod-m103: + download_dataset
==> mongod-m103: + echo ‘Downloading Dataset’
==> mongod-m103: Downloading Dataset
==> mongod-m103: + curl -s -o products.json.tgz
==> mongod-m103: + tar -xzvf products.json.tgz -C /dataset
==> mongod-m103: tar:
==> mongod-m103: /dataset: Cannot open
==> mongod-m103: : No such file or directory
==> mongod-m103: tar:
==> mongod-m103: Error is not recoverable: exiting now
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

  1. Also when I run ‘vagrant SSH’ I get some errors. Need assistance from you to proceed further.

Must redirect to new repository for old Vagrant versions
Welcome to Ubuntu 14.04.6 LTS (GNU/Linux 3.13.0-168-generic x86_64)

System information as of Tue Apr 16 05:27:44 UTC 2019

System load: 0.0 Processes: 84
Usage of /: 4.9% of 39.34GB Users logged in: 0
Memory usage: 8% IP address for eth0:
Swap usage: 0%

Graph this data and manage this system at:

New release ‘16.04.6 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

  1. When I run the validate_box I get the below:
    vagrant@vagrant-ubuntu-trusty-64:~$ validate_box
    validate_box: command not found

What am I missing?

  1. Since the setup itself taking more time for windows user unable to proceed to lesson 1, without the validation key. suggestion to have the first lesson moved to next week. I am struck and need support as I couldn’t complete the validation, advice!
1 Like