Issue with configuring rsync

I have looked at the other post regarding this issue, and I have also added the environment path to a different line, as shown below.


I still can only get ssh to work, though rsync still outputs “‘rsync’ is not recognized as an internal or external command, operable program or batch file.”

Please try restarting the machine.


am having the same type issue.

I am also having this issue. I have rebooted my machine and still having the issue.

I restarted my machine and I am still getting the same issue as before. The command line recognizes ssh but does not recognize rsync.


Instead of configuring the Environment Path, I simply changed the directory in the command prompt from the default to “C:\MinGW\msys\1.0\bin”. I know doing that defeats the purpose of being able to access the contents of MinGW globally (which is what, I assume, configuring the Environment Path does), however, at least I am getting some kind of results from the ‘rsync’ rather than nothing.

Hi @Kyle_51857,

Please can you try this way from your command line:

 setx path "%path%;C:\MinGW\msys\1.0\bin" 


1 Like


I ran the command asked for, and it did not work.

Make sure you update the Path under System Variables and not under User Variables

I tried it and I still get the same output for rsync where it says “rsync error: syntax or usage error (code 1) at /usr/src/rsync/rsync-3.0.8/main.c(1420) [client=3.0.8]”