Issue in the vagrant up --provision command -> It gets stuck while curling to s3.amazonaws

After running vagran up --provision command, it makes a lot processes but it gets stuck in this line:

mongod-m103: + curl -s -o products.part2.json.tgz

It doesn’t do anything else after this line, I’ve had to wait hours to see if it continue to install, but it never do anything after that line.


Thanks for reading.

May be some firewall blocking your downloads

Are you able to download the file by clicking on the link?
Please check our forum for manual fix to a similar problem

1 Like

Hey @Ramachandra_37567, do you have the link for manual fix, the one you say is similar to this one?

I clicked on the linked and it let me download the json file. But i don’t really know how to fix it. I also checked the firewall and it’s off. I’m working on MacOS.

Thanks for your answer.

Hi @Juan_Camilo_75135,

I would suggest you to follow the below steps and see if this helps.

  1. Destroy the box
    vagrant destroy
  2. Make a copy of the provision file
  3. Open the original provision file in a text editor, scroll all the way to the bottom, comment out the following lines using this character “#” and save the file:

  1. Provision and ssh into the box
    vagrant up
    vagrant ssh
  2. Inside the box, let’s see the results when you ping the repo::
  3. In the provision file, find the function below, take each line one-by-one and run it until it errors:


Muskan, thank you very much for your quick answer.

When I realized I could download the file directly in the browser, I ran the vagrant up --provision command again and it worked! Thank you for your help.