Installation issue on astronomer cloud running ubuntu


I’m trying to install mongodb in a docker image on astronomer cloud which runs Ubuntu.

* sudo apt-get install -y mongodb-org
Reading package lists…
Building dependency tree…
Reading state information…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mongodb-org : Depends: mongodb-org-shell but it is not going to be installed
Depends: mongodb-org-server but it is not going to be installed
Depends: mongodb-org-mongos but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
The command ‘/bin/bash -o pipefail -e -u -x -c sudo apt-get update && sudo apt-get install -y mongodb-org’ returned a non-zero code: 100

I have tried to install the dependencies before.
RUN sudo apt-get install libcurl4 openssl

and i have to tried to check if it there are failed installation which seems as it should be.
RUN sudo dpkg -l | grep mongo

Are there any more ways to troubleshoot this?