I never can connect to the m001 shell with the provided connection strings

Almost every time I have to connect to the shell in the IDE for a lab, I get various errors. The most common one is this:

DNSRecordTypeMismatch: A Domain Name cannot have tokens other than dash or alphanumerics.

This is the connection string:

user@M001# mongo “mongodb+srv://:@.mongodb.net/admin”

I’ve tried this course on multiple computers, browsers, and operating systems; all with the same results. Anyone else having this trouble?

Please share your connect string for us to check
You can create a test user and share the credentials

1 Like

The connection is posted in my question under the error that gets returned.

No.
That is not full connect string.Is that what you tried?
Where is uri name in your string?

1 Like

Remember to define :@

You need a user and a cluster to connect.
If not defined mongo doesn’t know who you are and where do you want to connect.

Hope this solves your problem.

And btw, this link user@M001# mongo “mongodb+srv://:@.mongodb.net/admin” has omitted information because the website prevents you to sending your info by accident. So remember to fill username, password and the cluster.

Thanks Guilherme_Silva1. That helped.

No problem! Glad I could help.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.