I get an error when I try to adjust the minimum oplog window

Hey, hope someone can point me in the right direction.

I’m getting repeated “Replication Oplog Window has gone below 1 hours” alerts over the past few days, after an application change that resulted in lots of bulk writes. In Atlas cluster config, there’s an option to set a minimum oplog window - my understanding is Atlas will then auto-scale the oplog size to guarantee that minimum window.

When I try to set this value, I keep getting the error “Additional permissions are required to access the requested resource”. I’m logged in as the account owner so I don’t think it’s an issue with my permissions?

Any tips on getting past this?

I left it for a few hours and tried again, and this time it worked. Strange!

1 Like