HTTPS Endpoint "Verify Payload Signature" authorization failing

Hi all,

I am trying to setup a few HTTPS Endpoints to perform user management functions. The backing functions have been defined and are working as expected when Request Validation is set to No Additional Authorization. The problem comes in when the validation is set to Verify Payload Signature.

When I try to call the endpoint using curl as described in the example I get the following error back “expected signature method to be sha256”.

I have confirmed that the secret being used to generate the hash is the same as the one configured on Atlas (in the test app it was simply 12345). The hash was generated using the function described in the documentation, other languages were also tested but the same end result.


The function is configured with System authentication and was tested both as Private and Public. I have also tested with the function configured to use Application Authentication and an api key but still no change.

Any assistance would be appreciated.


Solved my issues, the documentation says to use Endpoint-Signature::sha256=<hex encoded hash> but this is wrong, there should only be a single : e.g Endpoint-Signature:sha256=<hex encoded hash>

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.