How long did it take for MongoDB to install for you?

It has been installing for over 2 hours, what were your experiences ?

Have the same problem!! is it normal to take that long?

I ended up installing an older version, not sure why but that was the only thing that worked for me. Lost 2 days fighting this with no response from anyone, hope this helps you out.

Did the same thing last night, did work. Got a little behind too, we still can make it.

I have been trying to run the mongo shell all day and keep getting an error message though. Have you tried to run this yet ?
mongo "mongodb://,," --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

It is telling me there is an issue with my version ?

I installed the 3.6.8 version and it did wok just fine, I access to a different DB tough. I will put the command I used. change the test DB to the local DB.

mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

Hope it works for you!