Having trouble downloading Compass

I am having trouble downloading the compass and am stuck on being able to complete the course.

I am using Windows 8.1 64 bit

It would be helpful if you told us exactly what you’re having issues with :slight_smile:

What are you doing? What are you expecting to happen? What is happening instead? Etc… Screenshots, errors, etc…

I went to the following link to download compass on my PC.


I tried selecting 1.16.3 (stable) and 1.16.3 community editions for Windows 7+ 64 bit. I then clicked on Download button. The download won’t start for me. For either of the options that I tried. I didn’t get any error message.

That’s remarkable. Just tried it and works fine for me.

Could you perhaps try another browser? Could be some script on the site failing in your browser.

In the meantime I’m trying to find the direct download path. See if I can give you that.

Thank you so much. It worked fine in Firefox. I have downloaded and installed it.

Cool! Glad to hear it worked out for you!