$group and Accumulators - suspicious option

While trying various RegExps I am getting the same result from my aggregation request. The result is provided as an option (an answer) for M121.CH3. L1. But the option (answer) is wrong.
Could somebody give me a piece of advice about what I might be doing wrong here?
My general query flow: filter on existence of “awards” field -> filter on /[W|w]on [0-9]+ [O|o]scars?/ -> $group…

1 Like

When doing that Lab, i had to run the command and see the output. There are a few weird entries.

If this doesn’t help, please include the full query you wrote.

PS: I believe the problem in your regex may be the s you don’t really need it if you won 1 Oscar. I would also try a fully case-insensitive query, just in case /query/i

I don’t think that the s is the problem because it is followed by the ? mark. Which means that it could rezer be present or not. I’ve tryed your approach with case insensitive exps and still get the same resalt as before. I belive I might not share my query due to rules of these discussions. But I may share the count of the result of my query - my query has retrieved 914 documents from the movies collection. Did your query extracted the same ammount?

oops, sorry, didn’t see ?.

Yes, I get that too. So it may be for the next, last stage.

your pipeline can be shared as long as you surround the code with this:


This will blur the code.

I see… So here is my pipeline:

I’ve found the root cause of my problem. I’ve mixed up the $stdDevPop and $stdDevSamp functions!
@Santiago_Miranda thank you for looking into this and helping me with this issue. :slight_smile:


You’re welcome and good luck for the next steps :slight_smile:

1 Like