Google OAuth needs domain verification

So I have set up my android app to include google login as a means of authentication. In the google api console, I created a OAuth 2.0 Client with the type as a web application using “” as an authorized uri. However, there is a 100 person user cap unless the the app is verified in google api console. Verification requires that I verify ownership of the callback domain. Has anyone ran into this? I obviously don’t own, so how do I progress with the verification process?

Screen Shot 2021-09-27 at 4.45.40 PM
Screen Shot 2021-09-27 at 4.43.47 PM

Screen Shot 2021-09-27 at 4.42.38 PM

Any advice will be appreciated.

Hi @Deji_Apps,

I don’t quite understand your problem here. Please, add more information:

  • you are working on an Android App, and you are using the Android Realm SDK, right?
  • you have a MongoDB Realm App created , and you want to add Google Login Auth to your Realm App? Or are you just using the Realm SDK as local persistence?
  • in the case of having a MongoDB Realm App, adding Google Login is quite simple, just follow this guide.

As you can see, your users, interacting with Realm will use Google Login to log in your Realm App. Right now I feel you’re doing it the other way around (from Google → MongoDB Realm)

Does this help you? Let me know if we can help with anything else!

Thanks for replying.
I am workin on an Android App, and I am using the Android Realm SDK.
I do have a MongoDB Realm App created, and I did add Google Login Auth. I did follow the guide to set up Google Login except for the part in the screenshot below.

In the screenshot above, it says to set up the application type in Google api console as android, but if you do that it does not give you a client secret as needed in step 3 for mongoDB’s authentication provider configuration. So I choose the application type as a web app so that I can have a client secret to put into MongoDB authentication provider.

Setting up OAuth as a web app in google api console however requires a redirect URI’s for which I used “”.

What I was unaware of until I started testing my app was that in google api, your redirect uri’s needs to be verified that you own the domain or it sets a limit of 100 users that can use the google login.

So my problem is that if I follow the mongodb guide to the letter and set up my OAuth in google api console as an android app, I won’t get a client secret to put into mongo’s authentication provider configuration. But if I set up my OAuth as a web app, I get a client secret, but I am required to verify that I own the mongodb callback url, which I don’t.

Did you come to any resolution to this problem?