Getting mgerenatejs error indexStats part4

Hello Community,

I tried to look to different discussion about this issue but i didn’t find an answer to mine.
After installing mgeneratejs with npm, I’m able to use it with it’s basic example :

But when i want to read my json file from shared directory, i get the error bellow, I have tried with -n 5 and
-n 10000, whathever the -n value, with or without sudo, I get the error bellow :

@Mohammad_89759 , @DHz , @Eoin_Brazil , @Sonali_Mamgain : I have seen your old discussion, but not able to find an answer. Anyone can Help ? Thank you

Regards
Otmane

Hey @Otmane_77759,

Have you tried the below given steps:

It seems to be helpful, try the above steps and let us know the status of your issue. We are here to help you out!

Thanks,
Kushagra

Hello @Kushagra_Kesav

Thanks for your replay
Yes I tried these steps, bellow a screen shot, I can use basic example of mgeneretjs to generate data, but I’m not able to use it like shown in the course, I tried many ways, you can see that in picture 2 and 3 :

Hi @Otmane_77759 ,

I am able to replicate the error and while I debug and find the reason for this error please share the following information:

  • The version of mgeneratejs using the command: mgeneratejs --version
  • Upload the file mgenerate_userdata.json

Feel free to reach out if you have any additional questions.

Kind Regards,
Sonali

Hello @Sonali_Mamgain

Here is mgeneratejs version :

image

I uploaded mgenerate_userdata.json into shared folder, and bellow it’s content :

I have another question, when i launch sharded cluster by mtools, i got some alamring messages of mongod and mongos, I don’t see that in the course, and don’t understand why, thank you again :

Best Regards
Otmane