Getting error while executing VBoxManage within the "vagrant up" command

The error is the folloing

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg *)" at line 95 of file VBoxManageHostonly.cpp

I tried the fix offered here:
But I already Secure Boot disabled.

There’s another hostonlyif thread but the stack trace is different. In your case it looks like a VirtualBox component didn’t install correctly. Suggest you uninstall VirtualBox and reinstall it again. And ensure that you install it with a user that has the right permissions too.

I couldn’t install VB either. I solved it by going to the terminal within the Mac’s recovery mode and using the following command.

spctl kext-consent add VB5E2TV963
1 Like

Hi @Jesus_69490,

Thanks for sharing the solution with us.

Shubham Ranjan
Curriculum Services Engineer