Geospatial query does not work

I was trying to do Lab 1.7 however, I did get an options of “Drag to build a query” on Map?
Also the “$centerSphere” operator does not appear in the suggestion when trying to Write a query.


I have the same problem. I’m holding the shift key and the circle doesn’t appear.

also having the same issue with the circle

Same probleme here, I hold shift and nothing.

I was also having this same issue, and just skipped this question.

This geospatial query didn’t work on windows 10 but in ubuntu 18 it works well.
“$centerSphere” is not appearing in ubuntu suggestion too but its working fine.
you should try it.

Same issue, shift does nothing

May be something changed with new versions?Course instructors can help
I tried with older version 1.16.0.It worked
After upgrading to 1.19.0 does not work
Screen shots attached


Above is from latest version.Only box appears when you press shift+drag

Would be great to hear from the course instructors on this since the assignment is due today. I’m having the same problem. Thanks!

Hi all,

In the latest 1.19.0 and 1.19.1 version of the Compass, you would not be able to generate a radius based geo-query. The Lab 1.7: Scavenger Hunt, Part 3 is an ungraded lab. I would recommend you all to skip this lab at the moment and contiue with the course.

If you have any other issue, feel free to get back to us. Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer

We released 1.19.3 about 1 hour ago. The functionality is back. Instead of ctrl-click, use the button with the little circle.

Apologies for temporarily removing the functionality.

1 Like

@Shubham_13709 & @mmarcon

Yes it is working now. thanks a lot update.