Find function in Atlas

Hey everyone,
i’m new in Mongodb, i tried to find {“birth year”:”1961”} in atlas but it’s wrong and i don’t understand what’s the problem?

Hey @M1k3_Hrd1,

It’s probably a number. Try unquoting the year.

I’m thinking the problem is the field’s name because “birth year” have a space between the words…i just tried year’s value without the quote but persistance the problem

The field name birth year is definitively not the issue despite the space.

Please post a screenshot of what you are doing that shows the error you are having. Saying it is wrong is not enough information for us to see the specific problem. We do not know if you got an error, no documents or too many documents or simply the wrong answer to the quiz.

@M1k3_Hrd1 thanks for the screenshots,

  • Check the quotes, type them by hand.

  • "birth year":1961 is fine, but also "start station name": "Howard St & Centre St"

  • Combine them in the quert {.... , ....}.

Try that, and feel free to reach out if you don’t get what you expect, or anything like that.

Do you saing than i might try this way?
{“birth year”: 1961 , “start station name”: “Howard St & Centre St”}

Yes

Try the query you pasted as it is
Are you getting results?

Make sure you are using straight double quotes

1 Like

As already mentionned

and

I will repeat. Do not use the quotes that comes with cut-n-pasting. Enter the quotes by hand.

1 Like

I inserted the quotes by hand! But not working…i’m not stupid…the problem were the quotes by iPhone sorry!

1 Like