File [validateLab1.js] does not exist

After getting a correct result from db.movies.aggregate(pipeline).itcount() I proceeded to try and run load(validateLab1.js) in mongo shell but to no success. I also tried just running validateLab1, since that appeared to be a solution on a post I found, but that did not work. I did not do anything with the validateLab1.js file other than downloaded and extracted it in my downloads folder. Am i supposed to copy it or what is it that I am missing?

Hello, you need full path instead of ‘validateLab1.js’ , like this : load('/Users/user/Downloads/chapter1/validateLab1.js')


Hi there

I do have the solution but can not load the validateLab1.js file. It was also not mentioned somewhere in the course program.

I specified the full pass but can still not locate my file. I guess I am still connected with the host.
I have ny file downloaded to C:\MongoDir. Who can help here?

load(‘C:\MongoDir\validateLab1.js’) does not help :frowning:

I use mongo shell in a windows 10 environment within parallels on Mac. All the exercices went well but I can not load this javascript file validateLab1.js --> is this load an upload into the SaaS environment?

Can somebody support? I use my mongo DB version 3.6 installation.

Solved !!! Starting Mongo from the directory where I had the downloaded files helped!

@Rene_DoIT use double \ instead of single \