Faceted search in mflix UI

I got the lab to pass, but I wanted to see it work in the mflix UI. I set:
…{ host: “”, useFacets: true }…
in index.html

I then just did a python run.py

No change in the UI. Do I need to somehow force a rebuild of the UI to see this change?


I was wondering the same. I’ll poke around some more.

Hi there,

Have you tried an hard refresh in your browser after doing the change?

You should not need to do such a hard refresh.

This what it looks like with {useFacets: false} if you search for cast: Angelina Jolie

Here’s what it looks like with {useFacets: true} for the same search:

Make sure that you do select the type of search (cast in this case)!


1 Like

Hmmm, I’ll try again. That did not show up now, but that’s probably because I wasn’t searching by cast. It wasn’t clear to me that the faceted search would only work for cast-searches.

@Tess_Sluijter I am also having some issues with the UI for faceted search (for a while I thought the search function was what they ment, but was confuced since it isn’t faceted :))

I have tried a few options and ensured it’s not related to caching, so maybe this is a bug the needs to be fixed. It does working with this ticket harder through.