__exec support has not been enabled

Dear All,

When tried implementing the new feature - passing password as __exec in config file, facing the below issue -

net.tls.certificateKeyFilePassword.__exec support has not been enabled

Kindly assist.


You need to include --configExpand

Thanks for your prompt response:)

Could you please let me the steps to create the function to store the password and use in it config file using __exec.


This is a question for your organisation’s Solutions Architect and Data Architect.

Sorry my question is related to the course, as mentioned in the course - we can store the password in a function and call it in the config file.

But how to create the function as mentioned in the course:

__exec: “get_certificate_password”

How to create this “get_certificate_password” in Linux env.

I tried creating env variable, but it didnt help.

You’re asking a Linux question. Performing a quick Google search on “how to create a function in Bash” should have yielded some results. In any case, here are some basic steps:

# 1. Create script file
sudo vi /usr/local/bin/get_certificate_password.sh

# 2. Copy/Paste
echo -n 'm042password'

# 3. Change ownership to vagrant
sudo chown vagrant:vagrant /usr/local/bin/get_certificate_password.sh

# 4. Set Read + Exec permissions
chmod 500 /usr/local/bin/get_certificate_password.sh

# 5. Execute script to verify it works
bash get_certificate_password.sh