Errors Installing Dependencies (pip install -r requirements.txt)

Hi,

I need help in resolving the following errors I am getting in installing the necessary dependencies.

I had earlier installed PyCharm and PyMongo. I have now installed Anaconda Navigator and am new to it.

C:\Users\hmp\M220>activate mflix

(mflix) C:\Users\hmp\M220>pip install -r requirements.txt
Requirement already satisfied: appnope==0.1.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 1)) (0.1.0)
Requirement already satisfied: attrs==19.1.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 2)) (19.1.0)
Requirement already satisfied: backcall==0.1.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 3)) (0.1.0)
Requirement already satisfied: bcrypt==3.1.7 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 4)) (3.1.7)
Requirement already satisfied: bleach==3.1.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 5)) (3.1.0)
Requirement already satisfied: cffi==1.13.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 6)) (1.13.1)
Requirement already satisfied: Click==7.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 7)) (7.0)
Collecting decorator==4.4.0
Using cached decorator-4.4.0-py2.py3-none-any.whl (8.3 kB)
Requirement already satisfied: defusedxml==0.6.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 9)) (0.6.0)
Collecting dnspython==1.15.0
Using cached dnspython-1.15.0-py2.py3-none-any.whl (177 kB)
Requirement already satisfied: entrypoints==0.3 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 11)) (0.3)
Collecting Faker==0.8.13
Using cached Faker-0.8.13-py2.py3-none-any.whl (741 kB)
Collecting flake8==3.7.8
Using cached flake8-3.7.8-py2.py3-none-any.whl (70 kB)
Collecting Flask==0.12.4
Using cached Flask-0.12.4-py2.py3-none-any.whl (81 kB)
Requirement already satisfied: Flask-Bcrypt==0.7.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 15)) (0.7.1)
Collecting Flask-Cors==3.0.3
Using cached Flask_Cors-3.0.3-py2.py3-none-any.whl (15 kB)
Processing c:\users\hmp\appdata\local\pip\cache\wheels\7f\5f\29\94154c03b4c0d4755c692f5cf062ea1f452b20204402f12d2a\flask_jwt_extended-3.7.0-py2.py3-none-any.whl
Collecting Flask-Login==0.4.0
Using cached Flask_Login-0.4.0-py2.py3-none-any.whl (15 kB)
Collecting importlib-metadata==0.23
Using cached importlib_metadata-0.23-py2.py3-none-any.whl (28 kB)
Collecting ipykernel==5.1.3
Using cached ipykernel-5.1.3-py3-none-any.whl (116 kB)
Collecting ipython==7.8.0
Using cached ipython-7.8.0-py3-none-any.whl (775 kB)
Requirement already satisfied: ipython-genutils==0.2.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 22)) (0.2.0)
Requirement already satisfied: ipywidgets==7.5.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 23)) (7.5.1)
Requirement already satisfied: itsdangerous==1.1.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 24)) (1.1.0)
Collecting jedi==0.15.1
Using cached jedi-0.15.1-py2.py3-none-any.whl (1.0 MB)
Collecting Jinja2==2.10.3
Using cached Jinja2-2.10.3-py2.py3-none-any.whl (125 kB)
Collecting jsonschema==3.1.1
Using cached jsonschema-3.1.1-py2.py3-none-any.whl (56 kB)
Requirement already satisfied: jupyter==1.0.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 28)) (1.0.0)
Collecting jupyter-client==5.3.1
Using cached jupyter_client-5.3.1-py2.py3-none-any.whl (91 kB)
Collecting jupyter-console==6.0.0
Using cached jupyter_console-6.0.0-py2.py3-none-any.whl (21 kB)
Collecting jupyter-core==4.4.0
Using cached jupyter_core-4.4.0-py2.py3-none-any.whl (126 kB)
Requirement already satisfied: MarkupSafe==1.1.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 32)) (1.1.1)
Requirement already satisfied: mccabe==0.6.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 33)) (0.6.1)
Requirement already satisfied: mistune==0.8.4 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 34)) (0.8.4)
Collecting more-itertools==7.2.0
Using cached more_itertools-7.2.0-py3-none-any.whl (57 kB)
Collecting nbconvert==5.6.0
Using cached nbconvert-5.6.0-py2.py3-none-any.whl (453 kB)
Collecting nbformat==4.4.0
Using cached nbformat-4.4.0-py2.py3-none-any.whl (155 kB)
Collecting notebook==6.0.1
Using cached notebook-6.0.1-py3-none-any.whl (9.0 MB)
Requirement already satisfied: pandocfilters==1.4.2 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 39)) (1.4.2)
Collecting parso==0.5.1
Using cached parso-0.5.1-py2.py3-none-any.whl (95 kB)
Collecting pexpect==4.7.0
Using cached pexpect-4.7.0-py2.py3-none-any.whl (58 kB)
Requirement already satisfied: pickleshare==0.7.5 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 42)) (0.7.5)
Collecting pluggy==0.6.0
Using cached pluggy-0.6.0-py3-none-any.whl (13 kB)
Requirement already satisfied: prometheus-client==0.7.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 44)) (0.7.1)
Collecting prompt-toolkit==2.0.10
Using cached prompt_toolkit-2.0.10-py3-none-any.whl (340 kB)
Collecting ptyprocess==0.6.0
Using cached ptyprocess-0.6.0-py2.py3-none-any.whl (39 kB)
Collecting py==1.8.0
Using cached py-1.8.0-py2.py3-none-any.whl (83 kB)
Requirement already satisfied: pycodestyle==2.5.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 48)) (2.5.0)
Requirement already satisfied: pycparser==2.19 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 49)) (2.19)
Requirement already satisfied: pyflakes==2.1.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 50)) (2.1.1)
Collecting Pygments==2.4.2
Using cached Pygments-2.4.2-py2.py3-none-any.whl (883 kB)
Requirement already satisfied: PyJWT==1.7.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 52)) (1.7.1)
Collecting pymongo==3.7.2
Using cached pymongo-3.7.2-cp37-cp37m-win_amd64.whl (311 kB)
Processing c:\users\hmp\appdata\local\pip\cache\wheels\3f\eb\eb\9c92af38689e8071cdc3fc28a5f0ef17ef03f662acd129fc94\pyrsistent-0.15.4-cp37-cp37m-win_amd64.whl
Collecting pytest==3.3.0
Using cached pytest-3.3.0-py2.py3-none-any.whl (184 kB)
Collecting pytest-flask==0.11.0
Using cached pytest_flask-0.11.0-py2.py3-none-any.whl (7.2 kB)
Collecting python-dateutil==2.8.0
Using cached python_dateutil-2.8.0-py2.py3-none-any.whl (226 kB)
Collecting pyzmq==18.1.0
Using cached pyzmq-18.1.0-cp37-cp37m-win_amd64.whl (1.0 MB)
Collecting qtconsole==4.5.5
Using cached qtconsole-4.5.5-py2.py3-none-any.whl (121 kB)
Requirement already satisfied: Send2Trash==1.5.0 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 60)) (1.5.0)
Collecting six==1.12.0
Using cached six-1.12.0-py2.py3-none-any.whl (10 kB)
Collecting terminado==0.8.2
Using cached terminado-0.8.2-py2.py3-none-any.whl (33 kB)
Collecting testpath==0.4.2
Using cached testpath-0.4.2-py2.py3-none-any.whl (163 kB)
Collecting text-unidecode==1.2
Using cached text_unidecode-1.2-py2.py3-none-any.whl (77 kB)
Requirement already satisfied: tornado==6.0.3 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 65)) (6.0.3)
Requirement already satisfied: traitlets==4.3.3 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 66)) (4.3.3)
Collecting wcwidth==0.1.7
Using cached wcwidth-0.1.7-py2.py3-none-any.whl (21 kB)
Requirement already satisfied: webencodings==0.5.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 68)) (0.5.1)
Collecting Werkzeug==0.16.0
Using cached Werkzeug-0.16.0-py2.py3-none-any.whl (327 kB)
Requirement already satisfied: widgetsnbextension==3.5.1 in c:\users\hmp\anaconda3\lib\site-packages (from -r requirements.txt (line 70)) (3.5.1)
Collecting zipp==0.6.0
Using cached zipp-0.6.0-py2.py3-none-any.whl (4.1 kB)
Requirement already satisfied: colorama; sys_platform == “win32” in c:\users\hmp\anaconda3\lib\site-packages (from ipython==7.8.0->-r requirements.txt (line 21)) (0.4.3)
Requirement already satisfied: setuptools>=18.5 in c:\users\hmp\anaconda3\lib\site-packages (from ipython==7.8.0->-r requirements.txt (line 21)) (45.2.0.post20200210)
Requirement already satisfied: pywinpty>=0.5; os_name == “nt” in c:\users\hmp\anaconda3\lib\site-packages (from terminado==0.8.2->-r requirements.txt (line 62)) (0.5.7)
ERROR: spyder 4.0.1 requires pyqt5<5.13; python_version >= “3”, which is not installed.
ERROR: spyder 4.0.1 requires pyqtwebengine<5.13; python_version >= “3”, which is not installed.
ERROR: pytest-astropy 0.8.0 requires pytest-cov>=2.0, which is not installed.
ERROR: pytest-astropy 0.8.0 requires pytest-filter-subpackage>=0.1, which is not installed.
ERROR: astroid 2.3.3 requires typed-ast<1.5,>=1.4.0; implementation_name == “cpython” and python_version < “3.8”, which is not installed.
ERROR: spyder 4.0.1 has requirement jedi==0.14.1, but you’ll have jedi 0.15.1 which is incompatible.
ERROR: spyder 4.0.1 has requirement qtconsole>=4.6.0, but you’ll have qtconsole 4.5.5 which is incompatible.
ERROR: spyder-kernels 1.8.1 has requirement jupyter-client>=5.3.4, but you’ll have jupyter-client 5.3.1 which is incompatible.
ERROR: pytest-astropy 0.8.0 has requirement pytest>=4.6, but you’ll have pytest 3.3.0 which is incompatible.
Installing collected packages: decorator, dnspython, six, python-dateutil, text-unidecode, Faker, flake8, Werkzeug, Jinja2, Flask, Flask-Cors, Flask-JWT-Extended, Flask-Login, more-itertools, zipp, importlib-metadata, parso, jedi, Pygments, wcwidth, prompt-toolkit, ipython, pyzmq, jupyter-core, jupyter-client, ipykernel, pyrsistent, jsonschema, jupyter-console, testpath, nbformat, nbconvert, terminado, notebook, ptyprocess, pexpect, pluggy, py, pymongo, pytest, pytest-flask, qtconsole
Attempting uninstall: decorator
Found existing installation: decorator 4.4.1
Uninstalling decorator-4.4.1:
Successfully uninstalled decorator-4.4.1
Attempting uninstall: six
Found existing installation: six 1.14.0
Uninstalling six-1.14.0:
Successfully uninstalled six-1.14.0
Attempting uninstall: python-dateutil
Found existing installation: python-dateutil 2.8.1
Uninstalling python-dateutil-2.8.1:
Successfully uninstalled python-dateutil-2.8.1
Attempting uninstall: flake8
Found existing installation: flake8 3.7.9
Uninstalling flake8-3.7.9:
Successfully uninstalled flake8-3.7.9
Attempting uninstall: Werkzeug
Found existing installation: Werkzeug 1.0.0
Uninstalling Werkzeug-1.0.0:
Successfully uninstalled Werkzeug-1.0.0
Attempting uninstall: Jinja2
Found existing installation: Jinja2 2.11.1
Uninstalling Jinja2-2.11.1:
Successfully uninstalled Jinja2-2.11.1
Attempting uninstall: Flask
Found existing installation: Flask 1.1.1
Uninstalling Flask-1.1.1:
Successfully uninstalled Flask-1.1.1
Attempting uninstall: Flask-Cors
Found existing installation: Flask-Cors 3.0.8
Uninstalling Flask-Cors-3.0.8:
Successfully uninstalled Flask-Cors-3.0.8
Attempting uninstall: Flask-JWT-Extended
Found existing installation: Flask-JWT-Extended 3.24.1
Uninstalling Flask-JWT-Extended-3.24.1:
Successfully uninstalled Flask-JWT-Extended-3.24.1
Attempting uninstall: more-itertools
Found existing installation: more-itertools 8.2.0
Uninstalling more-itertools-8.2.0:
Successfully uninstalled more-itertools-8.2.0
Attempting uninstall: zipp
Found existing installation: zipp 2.2.0
Uninstalling zipp-2.2.0:
Successfully uninstalled zipp-2.2.0
Attempting uninstall: importlib-metadata
Found existing installation: importlib-metadata 1.5.0
Uninstalling importlib-metadata-1.5.0:
Successfully uninstalled importlib-metadata-1.5.0
Attempting uninstall: parso
Found existing installation: parso 0.5.2
Uninstalling parso-0.5.2:
Successfully uninstalled parso-0.5.2
Attempting uninstall: jedi
Found existing installation: jedi 0.14.1
Uninstalling jedi-0.14.1:
Successfully uninstalled jedi-0.14.1
Attempting uninstall: Pygments
Found existing installation: Pygments 2.5.2
Uninstalling Pygments-2.5.2:
Successfully uninstalled Pygments-2.5.2
Attempting uninstall: wcwidth
Found existing installation: wcwidth 0.1.8
Uninstalling wcwidth-0.1.8:
Successfully uninstalled wcwidth-0.1.8
Attempting uninstall: prompt-toolkit
Found existing installation: prompt-toolkit 3.0.3
Uninstalling prompt-toolkit-3.0.3:
Successfully uninstalled prompt-toolkit-3.0.3
Attempting uninstall: ipython
Found existing installation: ipython 7.12.0
Uninstalling ipython-7.12.0:
Successfully uninstalled ipython-7.12.0
Attempting uninstall: pyzmq
Found existing installation: pyzmq 18.1.1
Uninstalling pyzmq-18.1.1:
Successfully uninstalled pyzmq-18.1.1
Attempting uninstall: jupyter-core
Found existing installation: jupyter-core 4.6.1
Uninstalling jupyter-core-4.6.1:
Successfully uninstalled jupyter-core-4.6.1
Attempting uninstall: jupyter-client
Found existing installation: jupyter-client 5.3.4
Uninstalling jupyter-client-5.3.4:
Successfully uninstalled jupyter-client-5.3.4
Attempting uninstall: ipykernel
Found existing installation: ipykernel 5.1.4
Uninstalling ipykernel-5.1.4:
Successfully uninstalled ipykernel-5.1.4
Attempting uninstall: pyrsistent
Found existing installation: pyrsistent 0.15.7
Uninstalling pyrsistent-0.15.7:
Successfully uninstalled pyrsistent-0.15.7
Attempting uninstall: jsonschema
Found existing installation: jsonschema 3.2.0
Uninstalling jsonschema-3.2.0:
Successfully uninstalled jsonschema-3.2.0
Attempting uninstall: jupyter-console
Found existing installation: jupyter-console 6.1.0
Uninstalling jupyter-console-6.1.0:
Successfully uninstalled jupyter-console-6.1.0
Attempting uninstall: testpath
Found existing installation: testpath 0.4.4
Uninstalling testpath-0.4.4:
Successfully uninstalled testpath-0.4.4
Attempting uninstall: nbformat
Found existing installation: nbformat 5.0.4
Uninstalling nbformat-5.0.4:
Successfully uninstalled nbformat-5.0.4
Attempting uninstall: nbconvert
Found existing installation: nbconvert 5.6.1
Uninstalling nbconvert-5.6.1:
Successfully uninstalled nbconvert-5.6.1
Attempting uninstall: terminado
Found existing installation: terminado 0.8.3
ERROR: Cannot uninstall ‘terminado’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

open text file and remove the versions of the module then run it, it will give you good result.

bro send your email to nagarajun635@gmail.com because both of us in the same track.

It is much better to share you questions and answers with the whole community rather than having private conversation.

1 Like

thanks for giving advice?

I’m using Anaconda on Windows 7. This information is for current and future students who have problems successfully running pip install -r requirements.txt. I had a tough time with this task including dependency errors and network problems during updates. The following two procedures worked for me.

  1. Install the latest version of Anaconda but run mflix using Python=3.6. You can set this when you create the mflix environment.

conda create --name mflix python=3.6

  1. Run everything in the Anaconda CMD.exe prompt. This can be launched from a link from the Anaconda navigator. This ensures that the Python environment is correct. Once you create the environment you can also select it on the navigator application using the field “Applications on” so that all the tools will be launched in the right environment.

To recap: start Anaconda navigator, launch a CMD.exe prompt, create the mflix environment (see procedure 1 above), activate it, and then in navigator set “Applications on” to mflix. pip install -r requirements.txt should now run correctly.

Python experts probably don’t need this information but if you’re stuck on requirement problems this is what saved me.

3 Likes

When you say set it to “Applications on”, do you mean we should assign the mflix. pip install -r requirements as a string to a variable Applications on or…?

“Applications on” is a drop down menu on the Anaconda Navigator GUI near the top left corner. After making that selection then install and launch “CMD.exe Prompt” from that GUI. I’ve been done with this course for a while but I just tried this again and everything still works. I would be careful about installing application other then the cmd.exe from the Anaconda navigator as doing this caused me problems. MFLIX has pretty strict package dependencies and disturbing these causes problems.

Here’s the big picture. I later realized that my problems were being caused by old Python installations on my PC, some of them years old. I suspect this is common. So one approach is to try to find and delete all the old ones and clean up the path. The Anaconda Navigator CMD.exe Prompt also worked because it creates an isolated environment.

Hi David_18019,

Your suggestion to use the Anaconda Navigator really helped me out. I was getting the same error message as others over and over again, trying to run the requirements.txt without errors).

So, thanks!

1 Like