Error with MongoDB Atlas

Update is not supported on fields with special characters in Data Explorer.

Can anyone help?

Hi @fa26aaebc63537e60602cc6be13297d - Welcome to the community.

Can you provide some steps to reproduce this issue? Please include any example documents and the type of update you were trying to perform.

Based off the error message, you can try performing the update via mongosh or MongoDB Compass to see if the same update works on there.

Regards,
Jason

1 Like

Using MongoDB Atlas

If I create a new document with string: string (e.g. joe@gmail.com: hello) and try to update this document, I get that error.

Update: Just realised this issue is with the PERIOD symbol (.)
Any field created with it, I am unable to update that field

Still testing on Atlas

Further update: This issue does not happen when using MongoDB Compass

Hi @fa26aaebc63537e60602cc6be13297d,

I tried to reproduce this error but could not. Could you list step by step how this error is generated?

Please see my reproduction steps below which did not generate the error:

  1. Empty collection:

  2. Insert the document with the string you had provided:

  3. Update the document:

  4. Document successfully updated:

Note: I tried to leave the period in the document to try generate the error on update

Regards,
Jason

2 Likes