Error npm install. (HELP!)

I write npm install and get errors.

Have you tried running npm rebuild? I had similar issue with node-gyp, it solved that for me.

You need to install Python 2.7. Do not install Python 3 because this node-gyp does not support Python 3.
After installing Python 2.7, rerun npm install.

I intalled Python 2.7. Here the image of error.


It seems that there are more dependencies you need to install.
This is a known issue and the solution some people have presented in this thread seemed to have worked.

Hi @John_30772, @Nazar_20200, @Julia_70671,

Please take a look at the following post and let me know if you have any issues.


I did the same, but still have the error.

I tried and got an error.

nodemon -L ./index.js

[nodemon] 1.19.1
[nodemon] to restart at any time, enter rs
[nodemon] watching: .
[nodemon] starting node ./index.js
MongoParseError: URI malformed, cannot be parsed
at parseConnectionString (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\core\uri_parser.js:502:21)
at connect (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\operations\connect.js:266:3)
at ConnectOperation.execute (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\operations\connect.js:191:5)
at C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\operations\execute_operation.js:109:26
at new Promise ()
at executeOperation (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\operations\execute_operation.js:102:10)
at MongoClient.connect (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\mongo_client.js:216:10)
at Function.MongoClient.connect (C:\Users\Ayzrian\Desktop\mflix-js\node_modules\mongodb\lib\mongo_client.js:379:22)
at Object.connect (C:\Users\Ayzrian\Desktop\mflix-js\src/index.js:23:13)
at Module._compile (internal/modules/cjs/loader.js:776:30)
[nodemon] app crashed - waiting for file changes before starting…

You need to check your connection string in .env file.


There is no .env file inside folder.

Hi @Nazar_20200,

Please follow the README instructions carefully. You need to rename dotenv file to .env file.


I still have the same error.

Please share the contents of .env file.