Error in provisioning and ssh comands not recognised

You can run validate from anywhere
Looks like path issue
Please go that directory and run the validate

vagrant@m103:/var/m103/validation$ pwd
vagrant@m103:/var/m103/validation$ echo PATH /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin:/var/m103/validation vagrant@m103:/var/m103/validation

vagrant@m103:/var/m103/validation$ ls -lrt validate_box
-rwxr-xr-x 1 root root 83 Jan 13 08:30 validate_box

Sorry not quite sure what I’m trying to do here?
pwd returns /home/vagrant
echo just echo’s the path typed in
ls -lrt validate_box returns ls: cannot access validate_box: No such file or directory

There’s no /var/m103 directory.
I think the provisioning has not built all the directories and loaded in the required files etc?

Re-provisioning the vagrant may help here. :slight_smile:

Let me know if that helps.


Kanika I have tried that a few times. Is the problem the fact that when in the Vagrant Up command the script requests a key from that fails? no valid OpenPGP data found.
This can be seen in the screenshot supplied.

Yes, maybe. Are you using any firewall/antivirus ? If yes, disable and try again.

If you are on office network, then try from home network.


Kanika, I did have that problem originally but fixed it by installing vagrant proxy plug-in.
But fails at home as well now.

I’m down to start this course again today but still have this issue, please can you help. Please can you give some priority as this is the third attempt to try and complete the course.

Hi Russell_92217,

Sorry for your experience. Follow these steps thoroughly. Let me know if any step fails.

  1. Run vagrant destroy from m103-vagrant-env directory.
  2. Run vagrant global-status. Make sure mongod-m103 is not listed there.
  3. If it is present, run vagrant destroy <ID>.
  4. Open VirtualBoxUI, make sure it does not list mongod-m103 as well. If it does, right click and “Remove” the machine.
  5. Now, create a new directory and download the m103-vagrant-env again.
  6. Run vagrant up again.

Here are some screenshots:



Kanika, done exactly as you state and here’s the errors I get (screenshots)

It seems to be a problem when tryin g to access the private key, any ideas?

Found this solution working for someone.

Greetings, thank you for answering, I tell you that I resolved otherwise, edit the file provision-mongodb and added these lines

function update_apt(){
sudo apt-get update
sudo apt-get - and upgrade
sudo apt-get install -y dirmngr

and comment the line 63

Make sure you have anti-virus disabled and you can ping

Also, try removing hkp:// from provision-mongod file in URL, line: 57.


I’ve made all the changes recommended and still get the same error. Cant comment out line 57 as its a end of function indicator i.e. } Can you let me know which line to delete by it’s contents?
Screenshot attached but looks the same as before.

Also can ping

any update on this issue/request?

Sorry @Russell_92217, I am sorry for the delay. :frowning: Our team was travelling.

In provision-mongod file, make sure the line for keyserver looks like this:

sudo apt-key adv --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6

After saving this file, run vagrant provision again. After this, run vagrant up.

Let me know.


line is
sudo apt-key adv --keyserver --recv 0C49F3730359A14518585931BC711F9BA15703C6
which is the same bar the port

HI @Russell_92217,

Can you try replacing key as told in this post:

Let me know.


Kanika, sorry still fails see screenshots

Hi Russell_92217,

This problem might occur if you are behind corporate proxy and corporation uses its own certificate.

Here check the source:

There is no other reason which seems valid for this. But do let me know if this is not the case. Will try to look more.