ERROR: child process failed, exited with error number 1 - when setting up a replica set

You are indeed! :slight_smile:

You most likely have already created the first user at some point. Let me see the command you used to login.

I am very tired. Here in Brazil it’s 01:10 AM. I need to sleep. Tomorrow I will post. Thank u my friend.

Boa noite! :slightly_smiling_face:

Here we go
A few lessons ago, I created the following users:


Should I drop the users ‘m-103-admin’ and ‘root’ or all of them?
Você fala Português?

Before you ran show users, I want to see the mongo command you used to login.

PS: No I don’t speak Portuguese but I know a few words because I’ve visited in the past :slight_smile:

In this case, I used nothing but mongo --port 27017:

When I do the exercise and fork the 3 process (without using the sudo), connect mongo on port 27001, and use “show dbs” or “show users”, or whatever I get this message:


That is, I have permission for nothing.
I 'll try to drop the users.

The node running on port 27017 is a different replica set from 27001. You should be able to run rs.initiate() on port 27001.

I know that. I had to run on port 27017 in order to get the users cause I don’t have permission for nothing on port 27001.

That’s how internal authentication and replication works. You need to run rs.initiate() before you create the first user on the admin db.

It’s no use. I dropped all users that I had. But I keep getting no permission:

Before I explain, what is the output of this:
use admin
db.runCommand({getCmdLineOpts: 1})

All command that I run on port 27001 I have this output

on port 27017 I get this output:
image

You have already created the first user, so you need to login with those credentials.

See an explanation in this post.

If you don’t remember the credentials, then delete the data files and startup mongod from scratch.

I did it before and did not work. That’s why I drop all users. I’ll create it again and try again and again. Thank you for your patience. I think I do not have any time to finish the M103. I’ll try to solve this problem with calm and after start the course again.

What did you do?

You can’t drop users if you can’t login so I’m not sure what you’re referring to here. If you drop users on 27011 it has no effect on 27001 because they’re on different replica sets.

I know. Actually I tried everything even delete the users on port 27017. This is the last thing I have left even knowing that it will not work. I’ am willing re-install the mongo.

You haven’t explained what “everything” means?