Error: Cannot find module 'babel-core/register'

Hi team,

I am getting an 'Error: Cannot find module ‘babel-core/register’ after running npm install and npm start.

I have tried installing babel on its own: npm install @babel/core --save

not sure what else I am missing. please help.


1 Like

Hey @SabeloG

Are you sure this is posted in the right section? There is no reason to npm install in M001.

Are you talking about M220 JavaScript? I believe you are and therefore have moved your post to the right section.

However you can try this post’s solution

I’m exactly in the same situation, tried many solution, but still in vain :’(

Could this post help?

getting same error after using this GIT reop file also

Hi @24688_kewat,

You need to download Handouts ( and NOT the GIT one.

Also, please take a look here:


1 Like

I downloaded the Handouts (zip file) but still getting the exactly same error, tried a hell lot of methods, posted on stackoverflow, created a thread on npm community, searched a dozens of other forums from google, still stuck in the same situation :’(

Ok, have you tried to delete the entire folder and start from the beginning? Like re-downloading the zip to a fresh folder?

And if this still persist can you share a screenshot of the error?

1 Like

hello @Kanika,

Using this zip file, I am still getting the same error please provide any other solution, I am unable to proceed to the next lecture.


Hey @24688_kewat

Please see my post here for help.

Problem Resolved:- => npm -i npm@latest -g => npm audit fix
3. change .env file and connect to the cluster (make sure you add your IP to the ATLAS network)
4.connect to the cluster using SHELL - connection command provide on cluster => node index.js (instead of npm start)

And Bingo its Done…!
Thankyou @natac13 for support

1 Like