Error 14 when running with node1.conf

When I try to start a mongod process using the node1 configuration file I get:

ERROR: child process failed, exited with error number 14
To see additional information in this output, start without the “–fork” option.

I tried removing the fork but it just opens another command line.
Please help.

Thanks in advance.

First place to look is in the log file.

This is the error in the log file:

[initandlisten] Fatal assertion 28579 UnsupportedFormat: Unable to find metadata for table:index-24-3678829267007817470 Index: {name: user_1_db_1, ns: admin.system.users} - version too new for this mongod. See http://dochub.mongodb.org/core/3.4-index-downgrade for detailed instructions on how to handle this error. at src/mongo/db/storage/wiredtiger/wiredtiger_index.cpp 270
2020-03-31T21:49:16.546+0000 F - [initandlisten]

***aborting after fassert() failure

What is your os?
Where you are running the mongod commands?
Vagrant or local host?
Please paste snapshot

It looks like you have a data directory containing files from an old version. You should specify another directory in node1.conf. However you are probably doing a lab that requires a specific data path. I think the best is to move the existing directory into a safe place in case there is something important in there. Then recreate a new empty directory.

I am currently on Windows 10 (64-bits)
Am using a vagrant machine

And this is the log file for the configuration file:

Try removing the *.lock files if you are sure no mongod are runnning.

Removing the directory and making it again, then starting a mongod process with that same directory as a dbpath fixed my issue.

Thank you for everything.

Closing this thread as the issue has been resolved.