Hi, before unninstalling mongodb compass whenever i got that problem i went to windows services and click on start mongo service and everything run perfect, but now that i download it again, i can’t see the mongodb service on windows services, how can i run mongodb service in order to stop getting that error, because i know that the problem is that the service is stopped. thanks for your time

If it is just Compass uninstall & install you should be able to start your service
Can you see mongod exec under install/bin dir?
or did you try to start the service from cmd line or start mongod from cmd line

i tried unninstalling and reinstalling mongo, didn’t work. i can’t see the installation/bin dir, i don’t know how to start it from cmd line if you mean by going to the installation folder and running mongodb.exe i did it, and didn’t work, whenever i got that error i used to open task administrator from windows go to services tab and run mongodb, but now i can’t see mongo service

I meant netstart mongodb
What error you got when you run mongod?
It could be issue with user you logged in as
Also check local user vs network user while starting the service from stackoverflow threads

it’s not the user, im running it locally(and without user or password), the problem is that the mongo service is not running, and i can’t see it from windows services so that i run it manually, if there’s a cmd command to run mongo service please tell me, (i try to execute netstart mongodb and it says that the command is not recognized), the problem is not when i run mongo is when i try to connect using the localhost:27017 string given by mongo, also the only two directories i found on mongodb dir(where is installed) is local and resources, and thats it.

It is net start mongodb
Please refer to these docs
The user i am referring to is your computer user not mongodb user

thanks for the help @Ramachandra_Tummala luckily i could solve the problem, the thing was that when i unninstalled mongo i also deleted mongo 2008r2 plus ssl, that allowed me to run mongo as a service, now i can see and run mongo service. anyways thanks so much for your time and help