Download Windows 64bit Validator


I have downloaded the Download Windows 64bit Validator.

I am running windows 10 with all the latest upgrades and patches.

I also rebooted.

When I run the command validate_m320 example --file answer_schema.json all I get is
Error - Invalid JSON format in file: answer_schema.json

If I reduce the file to just {}, I get the same result.


Hi @Chris_02854,

You would typically receive this error message if the JSON syntax is not as expected; i.e. missing/extra comma, brace, quote, chevron, wrong datatype… etc. With {} you would receive a different error message.

Please refer to the documentation for datatypes and use the datatype listed in the Alias column for this lab. You’re also only expected to replace what is within the chevrons for the in_house field only, i.e. keep the chevrons and do not delete anything else.


I copy and paste the json and create the new file in the same directory. I make the change keeping all the brackets and this is the error
Error - Invalid JSON format in file: answer_schema.json

I’ll try a linux vm.

Let’s see a screenshot of the contents of your file. You’ll need to delete it once I’ve had a look.

I removed the picture as requested.

It looks alright. And it might sound silly but are you 100% positive that you’re pointing to the correct file? Worth double checking if you’re in the right working directory.
What editor are you using?

I’m using this:


and I’m using notepad++

Ok. Try the one that I used when I took this course.

Correct. I type vali and then tab. The file is completed for me. Then I type example --file and answer followed by the tab key to compete the file name.

Thus no typo’s.

there are only two things in that directory. The validator and the json file.

I am running as a regular user. I assumed I don’t need to run this with elevated privileges.

It wouldn’t execute if the your privileges were insufficient, so you’re right.

Did you try the validator file I uploaded to my last post?

I tried the file you used when you took the course.
Same error.


Interesting indeed! If you have access to another machine or VM, try it on there too.

I figured it out. I used Notepad and it worked.

The problem was notepad++.

Notepad is using UTF-8. I think notpad++ is using ANSI.

Thanks for all your help.

Hmmm that was why I asked what text editor you were using and when you said Notepad++ I thought it would be fine because that’s what I used when I did this course. However, mine is set to UTF-8. Click on the Encoding menu and change it there.

Good job! :+1:

Can anyone pls share link for M_320 validator for 32 bit windows machine

@Sujaya_51648 This thread is about the 64 bit validator. Suggest you create your own thread to ask about the 32 bit version.

PS: I don’t believe there’s one if it’s not listed