Data import problem

I see it’s not only me how suffers from such an annoying thing and every time somebody should play around. So does the good solution or explanation in reality exist?

OK$ mongo mongodb+srv://

BAD$ mongorestore --drop --gzip --uri “mongodb+srv://” data

I’ve already received maybe all possible error messages with the last one “cannot unmarshal DNS message

1 Like

Hi @Denys_82412,

Try to import data to your Atlas free tier cluster by following the instructions on the Command Line Tools page for data import/restore


You will find clear instructions on how to import the dataset.


1 Like

Hi, Norberto.

Yeap. It works. But the context is a bit different:

$ mongorestore --gzip --host mflix-shard-0/,, --ssl --username m220student --password m220password --authenticationDatabase admin data


$ mongorestore --drop --gzip --uri “mongodb+srv://” data

And who knows how many people gonna look again for such solution, firstly trying the different ways with README… What is not good at all.


If things don’t work from given documentation, why does such documentation exist, only to confuse beginners?


In Atlas after I click ‘Command Line Tools’. What should happen? I’ve clicked on it and nothing happens. Should a window pop-up? I’m using Google Chrome Browser. Thanks

Hi @An_19003,
It should be a new page like this:

Hi Norberto,

thanks for all the assistance so far! I was having the same issue as Denys, but I followed your instructions and the import worked, but the issue now is that only two sets of data where restored/imported. here is the screenshot :

what do you think the problem is?

Could someone help me, to know what may be happening?
This is the first option.

and this is the second option.

I do not work in any way, I do not know what may be happening.

Welcome @josealonso2209 to data import club,

Actually, with the first one, it could be anything. As MongoDB’s engineers over-engineered something. The former is not right because of missing data. If you don’t indicate some other folder it will be looking a folder ‘dump’. So finish your line with $ … data and it must work.


Is this documentation for real? I cant seem to import the data based on their guild-lines. mongoStore is returning command not found and so is mongo
any advice

1 Like

Hi @olalekan_ogundipe_04604,

Can you share the command that you’ve executed ?

After you’ve connected to the cluster with your mongo shell or Compass you should be able to see the following collections in your mflix database:

MongoDB Enterprise Cluster0-shard-0:PRIMARY> use mflix
switched to db mflix
MongoDB Enterprise Cluster0-shard-0:PRIMARY> show collections
comments       →  19.808MB /  0.004MB
movies         →  61.846MB /  0.004MB
sessions       →   0.138MB /  0.004MB
theaters       →   0.334MB /  0.004MB
users          →   0.028MB /  0.004MB
watching_pings → 180.198MB / 56.023MB

Is that not the case ?


Hi @Denys_82412,

Can you try again with the following format:

mongorestore --gzip --drop --uri "mongodb+srv://" data

The issue you are getting is related with the trailing connection options that mongorestore does not really like.

I agree, this should not be a friction point. Thanks for the feedback.

In any case, if you follow my instructions, and copy paste the mongorestore command from the Command Line Tools modal, this you will not get into this issue.


1 Like

hey I am getting this message and nothing else

am i doing something wrong here? im following the read me and its not working? do you guys have a screen shot on the right way to import data, you must excuse me as I have just recently considered learning MongoDb havent looked at the alternatives.

the application seems to be running

its working now. thanks just needed some time

I have the following problem

and I have no idea what causes it,
the documentation is a bit confusing to me
I have mongodb installed, I tried to make the connection and import the data but I could not see the application work normally … I do not know what to expect … the application runs and shows the loading spinner logo …and nothing else…Im stuck here…

Hi @santiago_75841,

Thanks for the screenshot.

The error while running mongorestore command means you need to add “Mongo Bin path” to your environment variable.


Let me know how it goes!


thanks kanikasingla, it works

Thanks, that worked for me (when replacing 6y01q wirth the corresponding code in my uri). That command wasn’t clear to me from the instructions in the course materials.

EDIT: perhaps I spoke too soon… when trying to start the MFlix application, this happens:

$ npm start
> server@1.0.0 start /home/jsiks/Sites/mflix-js
> nodemon -L ./index.js

[nodemon] 1.17.5
[nodemon] to restart at any time, enter `rs`
[nodemon] watching: *.*
[nodemon] starting `node ./index.js`
Error: querySrv ENOTFOUND
    at QueryReqWrap.onresolve [as oncomplete] (dns.js:196:19)
[nodemon] app crashed - waiting for file changes before starting...